Ipswitch IMail Server is part of the Ipswitch family of tools and services. Learn More »

Try IMail Secure Server

Please complete the following form for your FREE 30-day evaluation
of IMail Secure Server.

It is recommended to read the IMail system requirements before installing.

 
A link to download the software will be sent to your email address.

IMail Secure Server - System Requirements

Software Requirements

  • Microsoft Windows® 2003 SP2 or 2008 Server
  • Microsoft .NET Framework 3.5 SP1
  • Microsoft .NET Framework 4
  • Microsoft Internet Information Services (IIS) 6.0 or later
  • Microsoft Data Access Component (MDAC) 2.8 SP1 or later

Hardware Requirements*

  • TCP/IP enabled NIC with a static IP address
  • An Intel® Pentium® 4 1 GHz or higher or an equivalent processor
  • 1 GB RAM minimum

* Microsoft Exchange ActiveSync® may require additional resources. Please read the system requirements document for details.